ダメじゃんEC-CUBE バージョンアップしたら、XREAに入らないよ~

ネットショップのソフトの、EC-CUBE がバージョンアップしたようです。

EC-CUBE Ver.2.1.2 (正式版)になったようです。

今回の目玉は、開発コミュニティで最も要望の高かった、共有SSLに標準対応した事ではないでしょうか?

早速、インストールする事にしました。

インストールの説明通りやってみました。

すると、パーミッションの確認画面で、変更の必要のあるファイルがズラズラと出てきました。

全部変更なんて、できね~よ

半分あきらめモードです。

しかし、”.htaccess”のファイルに”AddHandler application/x-httpd-phpcgi .php”を足す事によって、次の画面に・・・

でも、またエラーが出たよ。

そのエラーがこれ。

Warning: require_once(DATA_PATHmodule/Net/URL.php) [function.require-once]: failed to open stream: そのようなファイルやディレクトリはありません in /virtual/****/data/class/pages/LC_Page.php on line 25

Fatal error: require_once() [function.require]: Failed opening required ‘DATA_PATHmodule/Net/URL.php’ (include_path=’.:/usr/local/lib/php’) in /virtual/****/data/class/pages/LC_Page.php on line 25

よくみると、requiredの後の、”DATA_PATH”が展開されてね~よ。

htmlinstallindex.php の中で、

“define (‘DATA_PATH’, ‘”.$data_path.”‘);n”

されているようだが、これ以上はわかんないよ。

ところで、こちらのページのXREAのところを見ると、

EC-CUBE‐EC-CUBEが使えるレンタルサーバ

EC-CUBE 1 は、書かれているが、EC-CUBE 2は書かれていません。

つまり、ふつ~にやって、インストールできないって事かな?

また、すぐしたの”→インストール方法”のリンクをクリックしてみました。

でも、まだ何も書かれていませんでした。

う~ん、私は、まだテストの段階だからいいけど、

もし、本当にネット販売するのなら、今の状態だと不安だな~

前回やったときは、何とかインストール出来たけど・・・

検索してみると、EC-CUBE 2.0のバージョンで、コードを修正して、XREAに入れる方法を紹介しているところがあったみたい。

でも、根本的にわかっていない私は、コード修正は、ちょっと不安だな~。

ところで、EC-CUBE ってバージョンアップのリリースが遅いような気がするが・・・

ネットショップするなら、カートの部分だけ、CGIを使う方法などいろいろあります。

今のままで、EC-CUBE を使うのはどうかと思うようになってきたよ。

前回は、ネットショップするなら、EC-CUBE お勧めって思ったけど・・・

本当にネットショップするなら、他も検討した方がいいかも?

【追記】
この後、インストールする事が出来ました。

XREAに、EC-CUBE 2.1.2正式版をインストール出来たのだが!共有SSLダメじゃん
こちらもご覧ください。

スポンサーリンク

シェアする

  • このエントリーをはてなブックマークに追加

フォローする

スポンサーリンク

コメント

  1. コマメ より:

    コメントありがとうございます。

    早速、ご報告の通り試してみました。
    結果は、インストールできました。
    しかし、共有SSLで問題が・・・
    この件に関しては、こちらに書きました。
    http://kininaru.komame.jp/2008/05/07/1227/
    よろしければ、ご覧ください。
    ありがとうございました。

  2. 同じエラー文 より:

    同じエラー文が出て、この記事見てもうダメかと思ったけど
    Postgre で、UNICODEにして、DB作成したら(初期化)
    なんとかインストール成功したよ。

    EC-CUBEバージョン 2.1.2
    サーバは、coreじゃない普通のxrea

    このまま運用するのはかなり不安だけど・・汗